use strict;
my $str = 'server {
listen 80;
server_name localhost;
location /api {
rewrite /api/(.*) /$1 break;
proxy_pass https://host.name:1337;
proxy_redirect off;
proxy_set_header Host $host;
}
location / {
root /usr/share/nginx/html;
index index.html index.htm;
}
}';
my $regex = qr/(location \/api.*?proxy_pass\s*)([^ ;]+)/msp;
my $subst = '$1http://localhost:1234';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";