# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(location \/api.*?proxy_pass\s*)([^ ;]+)"
test_str = ("server {\n"
" listen 80;\n"
" server_name localhost;\n\n"
" location /api {\n"
" rewrite /api/(.*) /$1 break;\n"
" proxy_pass https://host.name:1337;\n"
" proxy_redirect off;\n"
" proxy_set_header Host $host;\n"
" }\n"
" location / {\n"
" root /usr/share/nginx/html;\n"
" index index.html index.htm;\n"
" }\n"
"}")
subst = "$1http://localhost:1234"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.