// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)(location \/api.*?proxy_pass\s*)([^ ;]+)").unwrap();
let string = "server {
listen 80;
server_name localhost;
location /api {
rewrite /api/(.*) /$1 break;
proxy_pass https://host.name:1337;
proxy_redirect off;
proxy_set_header Host $host;
}
location / {
root /usr/share/nginx/html;
index index.html index.htm;
}
}";
let substitution = "$1http://localhost:1234";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}