using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"location \/api.*?proxy_pass\s*([^\s;]+)";
string substitution = @"http://localhost:1234";
string input = @"server {
listen 80;
server_name localhost;
location /api {
rewrite /api/(.*) /$1 break;
proxy_pass https://host.name:1337;
proxy_redirect off;
proxy_set_header Host $host;
}
location / {
root /usr/share/nginx/html;
index index.html index.htm;
}
}";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}