#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^zh-han[st]/"
Local $sString = "These are URL paths:" & @CRLF & _
"" & @CRLF & _
"zh-hans/blog/uncategorized/123" & @CRLF & _
"zh-hant/blog/uncategorized/456" & @CRLF & _
"en/blog/uncategorized/789"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")