using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^zh-han[st]/";
string input = @"These are URL paths:
zh-hans/blog/uncategorized/123
zh-hant/blog/uncategorized/456
en/blog/uncategorized/789";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}