package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^zh-han[st]/`)
var str = `These are URL paths:
zh-hans/blog/uncategorized/123
zh-hant/blog/uncategorized/456
en/blog/uncategorized/789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}