import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^zh-han[st]/";
final String string = "These are URL paths:\n\n"
+ "zh-hans/blog/uncategorized/123\n"
+ "zh-hant/blog/uncategorized/456\n"
+ "en/blog/uncategorized/789";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}