package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sUi)\[p\](.+)\[p\]`)
var str = `[p]Получить ответ можно двумя способами[p]
[тег]самому задать вопрос[/тег]
[p]Получить ответ можно двумя способами[p]
[p]Получить ответ можно двумя способами
Получить ответ можно двумя способами[p]
[p]Получить ответ можно двумя способами[p]
[тег]самому задать вопрос[/тег]
[p]Получить ответ можно двумя способами[p]`
var substitution = "<p>$1</p>"
fmt.Println(re.ReplaceAllString(str, substitution))
}