using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<abr:rules>((?!subapplication=).)*subapplication=""(?!CM"")[^""]+""((?!<\/abr:rules>).)*<\/abr:rules>";
string input = @"<abr:rules>
<abr:ruleTypeDefinition>
<abr:code>ADE</abr:code>
<abr:ownership>
<abr:owner organization=""NT"" application=""DCS"" subapplication=""AM""/>
...lines...
...........
</abr:rules>
<abr:rules>
<abr:ruleTypeDefinition>
<abr:code>ADE</abr:code>
<abr:ownership>
<abr:owner organization=""NT"" application=""DCS"" subapplication=""CM""/>
...lines...
...........
</abr:rules><abr:rules>
<abr:ruleTypeDefinition>
<abr:code>ABB</abr:code>
<abr:ownership>
<abr:owner organization=""NT"" application=""DCS"" subapplication=""CM""/>
...lines...
...........
</abr:rules>
<abr:rules>
<abr:ruleTypeDefinition>
<abr:code>ADE</abr:code>
<abr:ownership>
<abr:owner organization=""NT"" application=""DCS"" subapplication=""CM""/>
...lines...
...........
</abr:rules>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}