# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:\[|(?!^)\G)[^]\s]*)\s/$1_/gm;t' <<< " [City tier] [nvarchar](max) NULL,
[Counting unit] [nvarchar](max) NULL,"