using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\[|(?!^)\G)[^]\s]*)\s";
string substitution = @"$1_";
string input = @" [City tier] [nvarchar](max) NULL,
[Counting unit] [nvarchar](max) NULL,";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}