const regex = /((?:\[|(?!^)\G)[^]\s]*)\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\[|(?!^)\\G)[^]\\s]*)\\s', 'gm')
const str = ` [City tier] [nvarchar](max) NULL,
[Counting unit] [nvarchar](max) NULL,`;
const subst = `$1_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);