use strict;
my $str = ' [City tier] [nvarchar](max) NULL,
[Counting unit] [nvarchar](max) NULL,';
my $regex = qr/((?:\[|(?!^)\G)[^]\s]*)\s/mp;
my $subst = '$1_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";