import re
regex = re.compile(r"((?:\[|(?!^)\G)[^]\s]*)\s", flags=re.MULTILINE)
test_str = (" [City tier] [nvarchar](max) NULL,\n"
" [Counting unit] [nvarchar](max) NULL,")
subst = "$1_"
result = regex.sub(subst, test_str)
if result:
print(result)