#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)BEGIN(?:(?!END)[\s\S])*EXCEPTION"
Local $sString = "BEGIN" & @CRLF & _
" xxx" & @CRLF & _
"END;" & @CRLF & _
"BEGIN" & @CRLF & _
" xxx" & @CRLF & _
"EXCEPTION" & @CRLF & _
" xxx" & @CRLF & _
"END;" & @CRLF & _
"BEGIN" & @CRLF & _
" xxx" & @CRLF & _
"EXCEPTION" & @CRLF & _
" xxx" & @CRLF & _
"END;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")