#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "href="[^"]*?\.pdf"
Local $sString = "<a href="test.html">test1</a>" & @CRLF & _
"<a href="test.pdf">test2</a>" & @CRLF & _
"<a href="test.html">test1</a>" & @CRLF & _
"<a href="test.html">test1</a><a href="testtime.pdf">test2</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")