// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"href="[^"]*?\.pdf"#).unwrap();
let string = "<a href=\"test.html\">test1</a>
<a href=\"test.pdf\">test2</a>
<a href=\"test.html\">test1</a>
<a href=\"test.html\">test1</a><a href=\"testtime.pdf\">test2</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}