use strict;
my $str = '<iframe id="donato-if" src="https://site.org/includes/donate.php?as_page=1&platform=wb&referer=http%3A//site2.org/web/20130129160928/http%3A//site3.ru/2005/10/29/prostranstvo-intellekta/"
<a href="https://site4.ru/lalala/http://site5.ru/" rel="external nofollow" class="url">lalala</a>';
my $regex = qr/\/\/([\w.-]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}