// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/\/([\w.-]+)").unwrap();
let string = "<iframe id=\"donato-if\" src=\"https://site.org/includes/donate.php?as_page=1&platform=wb&referer=http%3A//site2.org/web/20130129160928/http%3A//site3.ru/2005/10/29/prostranstvo-intellekta/\"
<a href=\"https://site4.ru/lalala/http://site5.ru/\" rel=\"external nofollow\" class=\"url\">lalala</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}