$re = '~(?>https?://\S+?/(?:(?!https?://).)*)(?!https?://)~';
$str = 'http://test.test/notwork.http://test http://test.test/com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);