const regex = /\w+@.+?(?="|\s)|(?<="phone":")\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+@.+?(?="|\\s)|(?<="phone":")\\d+', 'gm')
const str = `"email":"testEmail@test.com", "phone":"1111111111", "text":"sample text may contain email testEmail@test.com as well"`;
const subst = `*******`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);