import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<start>^[0-9]+)(?<message>[A-Za-z]+)(?<end>[^A-Za-z]*)$";
final String string = "1234test4321\n"
+ "4\n"
+ "0000oooo0000\n"
+ "4\n"
+ "Over!\n\n"
+ "1wat!\n"
+ "3\n"
+ "#23asd33\n"
+ "3\n"
+ "333asd3a\n"
+ "3\n"
+ "100dun2\n"
+ "3\n"
+ "Over!\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}