re = /(?<start>^[0-9]+)(?<message>[A-Za-z]+)(?<end>[^A-Za-z]*)$/m
str = '1234test4321
4
0000oooo0000
4
Over!
1wat!
3
#23asd33
3
333asd3a
3
100dun2
3
Over!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end