$re = '/c[ae]l[ae]nd[ae]r/m';
$str = 'calender
calendar
calandar
calendar
celandar
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);