using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(?:[\r\t\f\v ]*)(\(?[0-9]{3}\)?[-.● ]?[0-9]{3}[-.● ]?[0-9]{4})(?:\s*)";
        string input = @"email@gmai  (757)-749-0014  
(555) 555-5555
     (555)555-5555
5555555555
5555555555
(757)-749-0014   
   (757)-749-0014
INTERIOR DESIGNER RESUME SAMPLE 
47 Lance Street, Provincetown, MA 02657     (508) 047-1701        juliancrisp@email.com
Innovative interior designer with 10 years of experience in project management, space planning, and
computer-aided design. Proven ability to transform client ideas into beautiful, functional design
solutions. Skilled in color combinations, area improvement, and use of materials and illumination,
driving innovative and personalized creations.
Professional Experience
INTEGRATED DESIGN SOLUTIONS, PROVINCETOWN, MA
Interior Designer, October 2014–present
";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}