import re
regex = re.compile(r"(?:[\r\t\f\v ]*)(\(?[0-9]{3}\)?[-.● ]?[0-9]{3}[-.● ]?[0-9]{4})(?:\s*)", flags=re.MULTILINE)
test_str = ("email@gmai (757)-749-0014 \n"
"(555) 555-5555\n"
" (555)555-5555\n"
"5555555555\n"
"5555555555\n"
"(757)-749-0014 \n"
" (757)-749-0014\n\n\n\n"
"INTERIOR DESIGNER RESUME SAMPLE \n\n"
"47 Lance Street, Provincetown, MA 02657 (508) 047-1701 juliancrisp@email.com\n\n\n"
"Innovative interior designer with 10 years of experience in project management, space planning, and\n"
"computer-aided design. Proven ability to transform client ideas into beautiful, functional design\n"
"solutions. Skilled in color combinations, area improvement, and use of materials and illumination,\n"
"driving innovative and personalized creations.\n\n"
"Professional Experience\n"
"INTEGRATED DESIGN SOLUTIONS, PROVINCETOWN, MA\n"
"Interior Designer, October 2014–present\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")