using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"X([^X]+)";
string input = @"X
aaaa
X
bbbb
X
cccc";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}