$re = '/X([^X]+)/';
$str = 'X
aaaa
X
bbbb
X
cccc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);