package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<body[^>]*>)()`)
var str = `<body tag>
<body
tag- oh no it matched across
multiple lines>
<body alink="some_image_name_with_<brackets>_.png" >`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}