re = /(<body[^>]*>)()/m
str = '<body tag>
<body
tag- oh no it matched across
multiple lines>
<body alink="some_image_name_with_<brackets>_.png" >'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end