// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<body[^>]*>)()").unwrap();
let string = "<body tag>
<body
tag- oh no it matched across
multiple lines>
<body alink=\"some_image_name_with_<brackets>_.png\" >";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}