package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*)_([^_]+_[^_]+)__?\d$`)
var str = `CumulativeReport_cumulativeReportBins_CumulativeBinNetworksViews_totalSuccessfulHeartbeats_1
CumulativeReport_cumulativeReportBins_CumulativeBinNetworksViews_totalSuccessfulHeartbeats__1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}