re = /(?=(?>(?<match1>((?>\s|\b)\w{3}\s).+\s+\s(\d+\.\d{2})\s.*\s+\s(\d{1})\s.*)))/m
str = 'ABC FED GHK 45.00 60.00 30.00 4 5 5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end