#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mis)(?<!```html\s*)(<link href=.*?)(?=^\s*$)"
Local $sString = "" & @CRLF & _
"# PATTERNS" & @CRLF & _
"" & @CRLF & _
"## Style Blocks (2 patterns)" & @CRLF & _
"- ***Matches:***" & @CRLF & _
" - All `<style> any code here </style> blocks that aren't preceded by ```css + any amount of optional whitespace" & @CRLF & _
"" & @CRLF & _
">> NOTES FOR THE FOLLOWING PATTERN: " & @CRLF & _
" • This requires the `regex` library, not Python's built-in-crap" & @CRLF & _
" • This requires the `Single Line` (regex101) or `regex.DOTALL` (Python regex) flag" & @CRLF & _
"" & @CRLF & _
"### Pattern: Old version (would have replaced all punctuation with `punctuation` from the string library)" & @CRLF & _
" (?<!```css\s*)(\<style\>[\sa-z0-9\-\.\[\{\]\}:;#]+\<\/style\>)" & @CRLF & _
"" & @CRLF & _
">> NOTES FOR THE FOLLOWING PATTERN: " & @CRLF & _
" • This requires the `regex` library, not Python's built-in-crap" & @CRLF & _
" • This requires the `Single Line` (regex101) or `regex.DOTALL` (Python regex) flag" & @CRLF & _
"" & @CRLF & _
"### Pattern: Newest version (much better)" & @CRLF & _
" (?<!```css\s*)(<style>.*?<\/style>)" & @CRLF & _
"" & @CRLF & _
"## This does the same thing but for `<!DOCTYPE html> any code here </html>`" & @CRLF & _
"" & @CRLF & _
">> NOTES FOR THE FOLLOWING PATTERN: " & @CRLF & _
" • This requires the `regex` library, not Python's built-in-crap" & @CRLF & _
" • This requires the `Single Line` (regex101) or `regex.DOTALL` (Python regex) flag" & @CRLF & _
"" & @CRLF & _
"### Pattern:" & @CRLF & _
" (?<!```html\s*)(<!DOCTYPE html>.*?<\/html>)" & @CRLF & _
"" & @CRLF & _
"## This matches all blocks of code containing `<link href=>` up to, but not including, an empty line" & @CRLF & _
"" & @CRLF & _
">> NOTES FOR THE FOLLOWING PATTERN: " & @CRLF & _
" • This requires the `regex` library, not Python's built-in-crap" & @CRLF & _
" • This requires the `Single Line` (regex101) or `regex.DOTALL` (Python regex) flag" & @CRLF & _
"" & @CRLF & _
"### Pattern:" & @CRLF & _
" (?<!```html\s*)(<link href=.*?)(?=^\s*$)" & @CRLF & _
"" & @CRLF & _
"<br>" & @CRLF & _
"" & @CRLF & _
"(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)(><)" & @CRLF & _
"" & @CRLF & _
"<br>" & @CRLF & _
"" & @CRLF & _
"# TEST TEXT" & @CRLF & _
"" & @CRLF & _
"<br>" & @CRLF & _
"" & @CRLF & _
"<style>" & @CRLF & _
" .list-group-mine .list-group-item {" & @CRLF & _
" background-color: black;" & @CRLF & _
" color: white;" & @CRLF & _
" border-top: 1px solid #0091b5;" & @CRLF & _
" border-left-color: #fff;" & @CRLF & _
" border-right-color: #fff;" & @CRLF & _
" }" & @CRLF & _
" .list-group-mine .list-group-item:hover {" & @CRLF & _
" background-color: red;" & @CRLF & _
" }" & @CRLF & _
"</style>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"```css" & @CRLF & _
"<style>" & @CRLF & _
" .list-group-mine .list-group-item {" & @CRLF & _
" background-color: black;" & @CRLF & _
" color: white;" & @CRLF & _
" border-top: 1px solid #0091b5;" & @CRLF & _
" border-left-color: #fff;" & @CRLF & _
" border-right-color: #fff;" & @CRLF & _
" }" & @CRLF & _
" .list-group-mine .list-group-item:hover {" & @CRLF & _
" background-color: red;" & @CRLF & _
" }" & @CRLF & _
"</style>" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"<link href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css" rel="stylesheet" integrity="sha384-BVYiiSIFeK1dGmJRAkycuHAHRg32OmUcww7on3RYdg4Va+PmSTsz/K68vbdEjh4u" crossorigin="anonymous">" & @CRLF & _
"<div class="list-group list-group-mine">" & @CRLF & _
" <a class="list-group-item" href="https://bit.ly/3SICqay"><strong>Link to the SO Post</strong></a>" & @CRLF & _
" <a class="list-group-item" href="/path"><strong>Item 2</strong></a>" & @CRLF & _
" <a class="list-group-item" href="/path"><strong>Item 3</strong></a>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<br>" & @CRLF & _
"" & @CRLF & _
"##### Before Bootstrap" & @CRLF & _
"<!DOCTYPE html>" & @CRLF & _
"" & @CRLF & _
"<html lang="en">" & @CRLF & _
" <head>" & @CRLF & _
" <title>TABLE</title>" & @CRLF & _
" </head>" & @CRLF & _
" <body>" & @CRLF & _
" <table>" & @CRLF & _
" <thead>" & @CRLF & _
" <tr>" & @CRLF & _
" <th>Name</th>" & @CRLF & _
" <th>Number</th>" & @CRLF & _
" </tr>" & @CRLF & _
" </thead>" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Malachi</td>" & @CRLF & _
" <td>1-555-343-9867</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Steve</td>" & @CRLF & _
" <td>1-555-734-8857</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody>" & @CRLF & _
" </table>" & @CRLF & _
" </body>" & @CRLF & _
"</html>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"</br>" & @CRLF & _
"" & @CRLF & _
"<code style="color: #f51686; font-weight: bold; font-size: 16pt;"> The HTML </code>" & @CRLF & _
"" & @CRLF & _
"```html" & @CRLF & _
" <!DOCTYPE html>" & @CRLF & _
" <html lang="en">" & @CRLF & _
" <head>" & @CRLF & _
" <meta charset="UTF-8" />" & @CRLF & _
" <meta http-equiv="X-UA-Compatible" content="IE=edge" />" & @CRLF & _
" <meta name="viewport" content="width=device-width, initial-scale=1.0" />" & @CRLF & _
" <title>CSS Images</title>" & @CRLF & _
" <link rel="stylesheet" href="css/style.css" />" & @CRLF & _
" </head>" & @CRLF & _
"" & @CRLF & _
" <body>" & @CRLF & _
" <div class="container">" & @CRLF & _
" <section class="hero">" & @CRLF & _
" <figure class="profile-pic-figure">" & @CRLF & _
" <img" & @CRLF & _
" src="img/profile-800x800.png"" & @CRLF & _
" alt="profile"" & @CRLF & _
" width="800"" & @CRLF & _
" height="800"" & @CRLF & _
" title="Profile Pic"" & @CRLF & _
" />" & @CRLF & _
" <figcaption class="offscreen">Pookie Scrumptious</figcaption>" & @CRLF & _
" </figure>" & @CRLF & _
" <h1 class="h1">" & @CRLF & _
" <span class="nowrap">" & @CRLF & _
" Hello 👋" & @CRLF & _
" </span>" & @CRLF & _
" <span class="nowrap">" & @CRLF & _
" I'm Pookie" & @CRLF & _
" </span>" & @CRLF & _
" </h1>" & @CRLF & _
" </section>" & @CRLF & _
" </div>" & @CRLF & _
" </body>" & @CRLF & _
" </html>" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"<br>" & @CRLF & _
"" & @CRLF & _
"<code style="color: #f51686; font-weight: bold; font-size: 16pt;"> The CSS</code>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")