using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n\s*(<head>|<\/head>)";
string substitution = @"";
string input = @"<html>
<head>
</head>
<div>
<!-- some content -->
</div>
</html>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}