#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]{2}\d{2} (?:\d{4} ){3}\d{4}(?: \d\d?)?$"
Local $sString = "DE89 3704 0044 0532 0130 00" & @CRLF & _
"AT61 1904 3002 3457 3201" & @CRLF & _
"FR14 2004 1010 0505 0001 3" & @CRLF & _
"" & @CRLF & _
"R14 2004 1010 0505 0001 3" & @CRLF & _
"FR14 2004 1010 0505 0001 444" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")