package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]{2}\d{2} (?:\d{4} ){3}\d{4}(?: \d\d?)?$`)
var str = `DE89 3704 0044 0532 0130 00
AT61 1904 3002 3457 3201
FR14 2004 1010 0505 0001 3
R14 2004 1010 0505 0001 3
FR14 2004 1010 0505 0001 444
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}