import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]{2}\\d{2} (?:\\d{4} ){3}\\d{4}(?: \\d\\d?)?$";
final String string = "DE89 3704 0044 0532 0130 00\n"
+ "AT61 1904 3002 3457 3201\n"
+ "FR14 2004 1010 0505 0001 3\n\n"
+ "R14 2004 1010 0505 0001 3\n"
+ "FR14 2004 1010 0505 0001 444\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}