const regex = /^[A-Z]{2}\d{2} (?:\d{4} ){3}\d{4}(?: \d\d?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]{2}\\d{2} (?:\\d{4} ){3}\\d{4}(?: \\d\\d?)?$', 'gm')
const str = `DE89 3704 0044 0532 0130 00
AT61 1904 3002 3457 3201
FR14 2004 1010 0505 0001 3
R14 2004 1010 0505 0001 3
FR14 2004 1010 0505 0001 444
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}