# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[A-Z]{2}\d{2} (?:\d{4} ){3}\d{4}(?: \d\d?)?$"
test_str = ("DE89 3704 0044 0532 0130 00\n"
"AT61 1904 3002 3457 3201\n"
"FR14 2004 1010 0505 0001 3\n\n"
"R14 2004 1010 0505 0001 3\n"
"FR14 2004 1010 0505 0001 444\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.