use strict;
my $str = '(10 AND 20 AND (30 OR (40 AND 50)))
Into
[\'10\', \'AND\', \'20\', \'AND\', [\'30\', \'OR\', [\'40\', \'AND\', \'50\']]]';
my $regex = qr/(?=^(\((?:\w+\h*|(?1)\h*)*+\))$)(\()|(?<!^)\G(?:(\w+)(?=\h*\))|(\w+)|\h*|(\()|(\))(?=\h*[\w(])|(\)))/mp;
my $subst = '${2:+[}${3:+\'$3\'}${4:+\'$4\', }${5:+[}${6:+], }${7:+]}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";