#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\(\s*(.+?)\s*\?\s*(\(\s*)?(?(-1)(.+?)\s*\)|(.+?))\s*\:\s*(\(\s*)?(?(-1)(.+?)\s*\)|(.+?))\s*\)"
Local $sString = "( myCondition ? truePart : elsePart ) //done!" & @CRLF & _
"" & @CRLF & _
"( myCondition ? truePart : ( myCondition2 ? truePart2 : falsePart2 ) ) //done!" & @CRLF & _
"" & @CRLF & _
"( myCondition ? ( myConditionT ? truePartT : falsePartT ) : ( myConditionF ? truePartF : falsePartF ) ) //done!" & @CRLF & _
"" & @CRLF & _
"( myCondition ? ( myConditionT ? truePartT : falsePartT ) : falsePartF ) //done!" & @CRLF & _
"" & @CRLF & _
"\(\s*(.+?)\s*\?\s*(.+?)\s*\:\s*(\(\s*)?(?(-1)(.+?)\s*\)|(.+?))\s*\)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")