package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(\s*(.+?)\s*\?\s*(\(\s*)?(?(-1)(.+?)\s*\)|(.+?))\s*\:\s*(\(\s*)?(?(-1)(.+?)\s*\)|(.+?))\s*\)`)
var str = `( myCondition ? truePart : elsePart ) //done!
( myCondition ? truePart : ( myCondition2 ? truePart2 : falsePart2 ) ) //done!
( myCondition ? ( myConditionT ? truePartT : falsePartT ) : ( myConditionF ? truePartF : falsePartF ) ) //done!
( myCondition ? ( myConditionT ? truePartT : falsePartT ) : falsePartF ) //done!
\(\s*(.+?)\s*\?\s*(.+?)\s*\:\s*(\(\s*)?(?(-1)(.+?)\s*\)|(.+?))\s*\)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}