use strict;
my $str = ' /qgis/QGIS/pull/53256';
my $regex = qr/(.+\/)(.+)/mp;
my $subst = '[\\2](https://github.com/qgis/QGIS/pull/\\2)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";