re = /(?:https.+?linktr\.ee(?:%2F|.+?\/)):?\s?([a-zA-Z0-9_.-]+)/m
str = 'https:\\\\/\\\\/linktr.ee\\\\/TESTER'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end