# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:(?:\*)|(?:(?:[^<>()\[\],;:\s@\*]+(?:\.[^<>()\[\],;:\s@\*]+)*)|(?:\".+\"))+)@|\*@(?:\*\.)?)(?:(?:[^<>([\],;:\s@\*]+\.)+[^<>()[\],;:\s@\*]{2,})$"
test_str = ("# should match\n"
"*@*.open.ch\n"
"*@open.ch\n"
"pem@open.ch\n"
"pedro.mendez@open.ch\n"
"osag-mail-test@mail-test.opensystems.ch\n"
"this.\"is valid indeed #%&^\".stupid@foo.bar\n\n\n\n"
"# should not match\n"
"*@*open.ch\n"
"foo@*.bar.com\n"
"lalal.com\n"
"@example.com\n"
"foo*@example.com\n"
"f*o@example.com\n"
"foo@ex*mple.com\n"
"foo@ex.*.ple.com\n"
"tst@@open.ch")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.