// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(?:(?:(?:\*)|(?:(?:[^<>()\[\],;:\s@\*]+(?:\.[^<>()\[\],;:\s@\*]+)*)|(?:\".+\"))+)@|\*@(?:\*\.)?)(?:(?:[^<>([\],;:\s@\*]+\.)+[^<>()[\],;:\s@\*]{2,})$"#).unwrap();
let string = "# should match
*@*.open.ch
*@open.ch
pem@open.ch
pedro.mendez@open.ch
osag-mail-test@mail-test.opensystems.ch
this.\"is valid indeed #%&^\".stupid@foo.bar
# should not match
*@*open.ch
foo@*.bar.com
lalal.com
@example.com
foo*@example.com
f*o@example.com
foo@ex*mple.com
foo@ex.*.ple.com
tst@@open.ch";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}