$re = '`^\+\d{1,3}\s*\(?\d{3,6}\)?\s*[\d\-\s]{4,9}$`m';
$str = '+7 (903) 758-6666';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);