$re = '/^(\S+(?:.*\b(?=[MDCLXVI])M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3})\b(?= +\S))?) +(.*)/m';
$str = 'Vladimir Goth
Langraab III Landgraab
Langraab VII Landgraab
Léa Magdalena X Rouault Something
Anna Maria Teodora
Léa Maria Teodora II
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);